Max-Severity GitLab Vulnerability Exploited Against Alpine Linux
At a glance
- Severity
- CriticalCVSS 10.0
- Used in attacks
- Yes, 1 of 1 flaw named
- Flaws named
- CVE-2026-97229
- Reported by
- 1 outlet
A recent code execution vulnerability in GitLab was exploited one week after disclosure in a failed attack against Alpine Linux’s instance.
Tracked as CVE-2026-97229 (CVSS score of 10/10), the flaw stems from insufficient regular expression validation in Onigmo, Ruby’s regular expression engine.
The bug “could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration,” GitLab noted in an October 12 advisory.
According to Alpine Linux, a threat actor targeted its GitLab instance with a CVE-2026-97229 exploit on October 20 and 21. The attack failed, but the Linux distribution rebuilt the instance from scratch.
“Our checks show that the aports repository, packages, and the October 21 releases were not tampered with,” Alpine Linux notes.
It is still testing the GitLab instance before public release, and has reset all passwords, warning of observed automated login attempts using passwords compromised in other leaks.
Advertisement. Scroll to continue reading.
As part of the October 20-21 attack, the hackers used a newly registered account to send crafted CI configurations to Alpine Linux’s GitLab instance, crashing the worker process.
“In 4 of those crashes, the attacker got partway through the exploit and failed at the next step. The attacker also downloaded our GitLab container image, which suggests they were tuning the exploit to our exact build. We have found no evidence that the attacker ran code on the server, but we cannot rule it out,” Alpine Linux says.
Because the underlying vulnerability resides in Ruby, not in GitLab, and the Linux distribution’s image runs standard Ruby, the vulnerability was not patched after updating to GitLab 19.3.6.
“If you run GitLab with your own Ruby (from source or in your own container image) rather than GitLab’s packages, upgrading GitLab is not enough: you also need Ruby 3.3.13, 3.4.12, 4.0.9 or later,” Alpine Linux notes.
On Thursday, the US cybersecurity agency CISA added CVE-2026-97229 to its Known Exploited Vulnerabilities (KEV) catalog, urging federal agencies to patch it within three days, as mandated by BOD 26-04.
Related: TeamViewer Flaw Could Let Malicious Hosts Take Over Support Technicians’ Machines
Related: Adobe, Veeam, Juniper Networks Patch Critical Vulnerabilities
Related: Chinese Hackers Quietly Used Low-Severity ESXi Logging Flaw as Zero-Day
Related: Hackers Start Probing Fresh Oracle EBS Vulnerability
Originally published by SecurityWeek. © SecurityWeek. Written by Ionut Arghire.
Vulnerabilities referenced
- CVE-2026-9722910.0Critical
GitLab Community Edition and Enterprise Edition
GitLab Community Edition and Enterprise Edition contain a integer overflow or wraparound vulnerability that could allow an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.
Used in attacksAdded to CISA's list 2026-10-29 · Patch or advisory available
Full record →
Fastnexa security experts
This story involves a flaw attackers are already using. Are you exposed?
A Fastnexa penetration tester can check whether CVE-2026-97229 or anything like it can be used against your websites, apps and network.
Think you’ve already been hit? Don’t wait on a form: call or WhatsApp +1 (732) 454 2616. We reply within 1 hour, 24/7. Emergency help →
Coverage
One outlet has carried this so far.
2026-10-30 09:32 UTC
Related stories
- Barracuda Networks security advisory (AV26-1112)
Canadian Centre for Cyber Security · 2026-11-02
- BTCPay Server warns of hot wallet crypto thefts on outdated instances
BleepingComputer · 2026-11-02
- Mutipath TCP: Use and Detection, (Mon, Nov 2nd)
SANS Internet Storm Center · 2026-11-02
- Armadin Tests Find 88% of Severe Flaws Outside Vendor Advisories
Infosecurity Magazine · 2026-11-02
- Apple warns users in 99 countries of mercenary spyware
The Record · 2026-11-02